Archive for April 2014

Testing a new theme. The old one I’ve used for a long time always seemed a bit dark to me, so I’ll see if this one is better; at the least, it supports embedded Youtube videos, which the old one didn’t.

So, I bought a new laptop and it’s just about working. It’s a Toshiba L70-A-04g, which was the best option I could find in a local store. Mostly because of the 17″ screen, because I wanted something that would fit more text than the old 15″, but also because it has a HDD cover underneath, while the 15″ models I looked at typically required removing sixteen screws and then pushing a credit card in around the edge to unlatch the entire base.

It kind of works. I removed the Windows 8 HDD and installed my Linux SSD from the old laptop, then configured the BIOS to legacy boot, and… ended up at a black screen. Mint 16 doesn’t understand the backlight, so I had to add acpi_backlight=vendor to the boot command.

Unfortunately it also doesn’t work properly with the HD4600 Intel video driver. In the past, buying a machine that’s all-Intel has been the safest option, but not here. There’s a lot of video corruption as the driver starts, and some flickering pixels at the top of the screen. I suspect it’s a video timing bug that’s been fixed in the 3.15 kernel, but that won’t hit Mint for several months. The other option is to run in VESA mode, but then you’re stuck with software rendering and the CPU running flat out for video playback.

The touchpad is abysmal, for some reason they’ve combined the mouse buttons into the touchpad, they take a heck of a force to click, and, if you click one while your finger is on the touchpad, you have to lift your finger and put it back down to get the touchpad to recognize it again. The old one was far better.

So, it appears Libreoffice is now crashing regularly for no obvious reason, with a segmentation fault in libmergedlo.so; it seems to be a known bug that’s been around for months with no fix. This is particularly annoying because I save the file, do something, it crashes, and, when I restart it, the file I load is not the one I saved.

Since it’s crashed three times in the last fifteen minutes, this makes writing pretty damn tiresome right now. I presume it’s somehow graphics driver related, because it didn’t happen on the old laptop, but happens regularly on this one. That said, it’s also happened on my desktop machine at work.

Someone suggested uninstalling Java, and, since I did that, it hasn’t crashed. Which is weird, because I had the Java integration disabled before then. It may just be a coincidence.